Retrieving photo data from Flickr API
Quantitative processing in MS Access
- Spatial clustering in ArcGIS
- Mapping and Symbolization




Software:
MS Access 2003, 2007, 2010, 2013
or MS Access Runtime (free)

(See Software/AccessRuntime_x64 de-de.exe (64bit), AccessRuntime_x86_de-de.exe (32 bit))
Access Photo data processing form: <..\O2STEP\importdata.accdb >

ESRI ArcGis 10.1+, ArclInfo License

(Standard License may work, but slow due to using Buffer instead of Aggregate)

F||Ckl' AFCGIS TOOIbOX ..\O3STEP\O1_TOOLS\PhotoGeotagTools.tbx =

Recommended: Copy “01_TOOLS” Folder to <C:/01_TOOLS/ >

P hOtO Data TOOI klt <..\O1STEP\GetGeo.exe > (Windows 2007/2008 x64/x86 only)

(in case program does not run, install using <..\O1STEP\Setup_Files\setup.exe >

Optionally:
LibreOffice Portable for editing *.dbf-Files

(See <Software/LibreOfficePortable/LibreOfficeCalcPortable.exe >)

Preparations




Clip Data

Load data and choose clipping extent
..xmpm

GetGeo Too

3.8662180065564 -79.27734375 .
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eheree T nctions for more information. |

flon [ Hamilton , Amherst

- For clipping data from existing dataset

- OPEN <.\O1STEP\GETGEO.EXE >

- Open ClipData Tool (1)

- Load Folder <..\Input\> (2)

- areas with existing datasets are highlighted by red boundary
- Choose clipping extent by moving markers (3)

- Optionally use temporal constraints for photodata (4)

- Search will preview available photo data for criteria (5)

- Export will save photo data to < ...\Output\NAME\ > (5)
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- For retrieving new data from Flickr API
Open GetGeo Tool (1)

- Choose timespan for photo data (2)

- Choose spatial extent for photo data (3)
- Click ,,Show Map*

- zoom/pan to area

- click on LAT / LONG to update position

- Optionally, limit search to specific tags,
separated by comma (3a)

- Enter Name and click Export (4)

-  EXxport will save photo data to < ..\Output\NAME\ >




- Output folder < ..\Output\NAME\ >

contains datafiles + additional files

- Photos itself are not downloaded

- Datafiles contain comma separated photo data,
iIncluding URL to photo

- Select all datafiles..

ssing » 01STEP » Output » WLO1

Share with Print Burn

|| GridCoordinates.bd

| log.bd

| settings.bet | WLD1_Part1_844 Tilel.txt - Notepad
| WLO1_Partl 844 Tilel.bt | File Edit Format View Help

ID,Latitude,LongitudE,NAME,URL,PhotoID,Owner,UserID,DatETaken,UE1oadDatE,Views,Tagﬁ,MTagﬁ

. 540771,-80.553646,5t. Jacobs M111,httgs:fffarms.staticf11c r.com/7504,/15844733307_6&6b
.539394,-80.553796,Night-Time 5t. Jacobs Snowy Photowalk 9,https://farm8.staticflickr.
.539635,-80.55386,Night-Time 5t. Jacobs Snowy Photowalk 10,https://farm8.staticflickr.
.539635,-80.55386,Night-Time 5t. Jacobs sSnowy Photowalk 3,https://farm9.staticflickr.c
.539122,-80.55386,Night-Time 5t. Jacobs Snowy Photowalk 5,https://farmé.staticflickr.c
.54032,-80. 553249, Night-Time 5t. Jacobs snowy Photowalk 1,https://farm9.staticflickr.c

0 — 8




..and copy to folder
< 02STEP\INPUT\ >

Go to Folder
< ..\O2STEP\>

Copy
Importdata.accdb

Rename & open
new AcCcess
Database

 INPUT
, OLD
. QUTPUT
|8 jimportdata.accdb |

Prepare Access database




Enter name for Geotag Database Tools
Import table (1) L Fopor

Folder: \Inputy,

== CI I C k Importname: Impaortspecification:
Loads, and merges all *.txt files into one
Jc a *
a) L O ad tXt ) L table. Place files in subfolder '/INPUT/
-

[ Delete Importerrors ]

b) Add Primary ) [acprmary

Remove any - Processing A: Duplicates
duplicate data
entries (2):

2. Processing A: Duplicates

Name Qriginal: 'wL01_UID Column: PhotolD

Copies table and removes

Remowve Duplicates
| P 4| duplicates in specified column.




Export table to *.mdb
(ArcGIS 10.0 compatible database)

...data Is exported to
< ...02STEP\OUTPUT\*.mdb =

We will later use this file for mapping
photo location data in ArcGIS

, # 04_Processing » 025TEP » OQUTPUT

Share with = Burn »
Table: WLO1_UID

| (] | Export_WLO1_UID.mdb |
Save As: \Output,

Exports data from specified table to
+
Export *.MDB MDB compatible with ArcGis 10.

hotodata to ArcGIS




1/1 Done.
b)
Mame: WLO1_UID_DistCl
3. Processing B: Tags
Template: Taglist_templ

Table: WL01_UID_Dist
Sort Out Global: SortQutAlways

a) Clean Tag Data
Sort Out InStr *:|SortOutAlways_InStr

0/0 '
/ Output: Taglist WLO1_UID_DistCl

| Separate Tags |

Processing Taqgs

R

- Analyze available tags in dataset

- Clean Tag Data first (1)

(each tag is counted once per user)

- Remove tags based on stop list (2)

(optionally edit stop list first >

Tables: SortOutAlways and SortOutAlways InStr)




- Count distinct tags (1)
- ...duplicate list (2)..
- Select tags for clustering in ArcGIS .
- ..by first removing unwanted tags (3)
- .. humber of total tags Influences cluster processing time,
recommended: first 1000 or Iess)

3] Database Tnnls-x"{@ Taglist WLO1_UID_DistCl_Count "
TAGNAME ~ TAGCOUNT -

stjacobs 47
ontario 42
Taglist_WL01_UID_Distcl canada 35
Tags jacobs 11
waterloo 11
output: Taglist_WL01_UID_DistCl_
st 10
l Count distinct Tags ]h] l Duplicate J river
Table: Taglist_... Count | sky

Y Output, arange

l Export *.XLS Exports data fram specified table to tree
: Excel Spreadsheet.
trees
Export *. ¥LSX Exports data from specified table to Excel 2007 .
l i Spreadsheet (allows more than 65,536 rows). brldge
Exports data from specified table to SNOW

l Export *.DBF

* dbf table (Supported only in
Access 2010 and below).

= T = = T B Ml == IRt

winter




- EXxport table to

*.dbf File (only works in Access 2010 and earlier)
or *.xls File (Excel)

- Saved to < ...02STEP\OUTPUT\*.xls =

Taglist_ WLO1_UID_Distcl

Tags

: : ing » 02STEP » OQUTPUT - |4 |
Taglist_WL01_UID_DistCl_

Count distinct Tags ._J b} Duplicate | - Share with ~ Print  »  Z&

Table: Taglist_WL01_UID_| Dlsti 71| Export_WL01_UID.mdb
Folder: \Output\, | B9 Taglist_WL01_UID_DistCl_Count_Sel.xls |

Exports data from specified table to
Excel Spreadsheet.

I Export *.XLS

I Export *.XLSX Exports data from specified table to Excel 2007
Spreadsheet (allows more than 65,536 rows).

Exports data from specified table to
_{ *dbf table {Supported only in
Access 2010 and below).

[ Export *.DEF




I8 Waorks... » 04_Processing » -

- Share with = Print »

., D1STEP

|, D25TEP

., D35TEP

| GIS_DATA

| Software
|BasemapLayout.mxd |

.---'
(3
-

['|' Copy to04_Processing

- make a copy of BasemapLayout.mxd
- Rename & open file in ArcGIS

- Repair missing data links if necessary
Set paper layout to A1 Oversize or similar
(24.61 x 35.43 Inches)

- Display example photo data:

Enable Layer AllIPhotos TorontoRegion




sEmap ut_} . - Archap

Add XY Data
Edit View Bookmarks Insert Selection Geoprocessing Customize Windows Help
A table containing X and ¥ coordinate data can be added to the . )
map as a layer D Mew... Ctrl+MN !:) - | 1:357.704 - m @
Choose a table from the map or browse for another table: E‘ Open... Ctrl+0 IE‘ 9 :.; H gﬁ E,. T |
[ wio1_up =] E] @ save Ctrl+5 o x
} . Save As... o= e
Specify the fields for the X, ¥ and Z coordinates: X
Labeling = i B Q fa “h &
) - Save A Copy...
X Field: Longitude M i
il =
¥ Field: Latitude - Share As » | | Ia
Z Field: <Nones - Add Data v | 4 Add Data...
Coordinate System of Input Coordinates
Description: .
Geographic Coordinate System: - Pagd | %+ Add XY Data
Mame: GCS_WGS_1984 ; - : :

I

-

S _ _ Choose File > Add Data > Add XY Data
e — " Load < ..02STEP\OUTPUT\*.mdb >

Warn IT.IE if the resulting layer will have restricted functionality - X F i e ! d — LO n g itu d e
About adding XY data oK ] ’ Cancel ] - Y Fleld — Latltude

- Coordinate System of Input:
GCS _WGS 1984
(Edit > Geographic Coordinate Systems > World > WGS1984)
- Click OK to import data
- Right-Click > Zoom to Layer

- Project Features to WGS_1984_UTM_Zone_17N (Canada)...
- (Menu Geoprocessing > Search For Tools > Project Tool)
Save to < C:\01_TOOLS\O1 Input\PhotoLocationData.shp >




Edit View Bookmarks Insert Selection Geoprocessing i High : 254

Open

Cowes

CtriieN - b - =5
Ctrl+2 Joins and Relates

k i C\Users\AD\stud Rermove Open

EH Save Ctrl+5 | B3 Administratio Open this table. Shortcut: CTRL +
e B= ne_50m_pi Data double-click table name OR CTRL
Save As,., Edit Features T

= ne_S0m_u
O
Share As i = B ne_50m_a

Save A Copy...

Geocode Addresses..,

Display Route Events...
Display XY Data...

Properties...
Add Data “(I;; Add Data... i = rop&le

Table

ElN ML=
H Find and Replace...
% Select By Attributes... IA

e - For Access 2013, convert *.xlIs to *.dbf:

5 - Choose File > Add Data > Add Data...
Load Table from < ...02STEP\OUTPUT\*.xls >
- Right-Click Table = Open

- Choose Menu > Export

Turn All Fields On

Show Field Aliases

Arrange Tables 3

Restore Default Column Widths
Restore Default Field Order

et : - Export table as DBase Table to

Add Table to Layout

< C:\O1_TOOLS\O1 Input\Taglist.dbf >

Reload Cache

gk @

Print...

Reports 3
Export... I

Appearance..

Export

|| reflections
| | horse Exports the table to a new table.
|_| silos
town

o | | [ [en | enfen en fen (e onen [en fen o |onen |on fon @ | @ (o | @~ |~ |~ oo




(JDE A ataloq. ODpe D0IDAC ole

» »
OPE otoGeotag loc A0 s DOSE
ArcToolbox
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3)!: Calculate WElghtS ) C:\01_TOOLS\01_ Input'PhotolocationData.shp
}'ﬂ Cluster Photo Locations Him
pTag
%ba Merge Output C:101_TOOLS\D2_Outputoutput_%TagNameValue %.shp
5;,.;, Model Tagiist.dbf
zn SFIIIjEF C:\01_TOOLS\01_InputtTaglist.dbf
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Input RawData:

.. Single photo locations and tags

HimpTag:

.. Output cluster files for each tag in Taglist.dbf

Aggregation Distance:
.. Accuracy of processing: choose value based on

scale of analysis & final display size

“ba TagRunnerV1.1

oo |

Input RawData
C:\01_TOOL5Y1_Input\PhotolocationData. shp

HImpTag
C:\01_TOOLSY2_Outputioutput_%%eTagMameValue%s.shp

Taglist.dbf
C:\01_TOOLSY01_InputiTaglist. dbf

Aggregation Distance
10000 |Meters

-

[ K _] rl Cancel ] [En'u'irnnments... ] [ Show Help = ]

Generate Taqg Clusters




- Output Files are saved to..
< C:\01_TOOLS\O2_Output\ >
- Select all output files and Merge to a single file using Merge
_ (Data management Tools)
(Menu Geoprocessing > Search For Tools > Merge Tool)

- Or: Use Tool PhotoGeotag Tools > “Merge Output”

‘% Merge

b oD e

Contents | Preview | D&ac:‘iptinn|

Mame

Input Datasets

C:\01_TOOLsY2_Outputloutput_afternoon.shp
C:\01_TOOLS\02_Outputiputput_abandoned.shp
C:\01_TOOLSY02_Outputhputput_abandonedhouse.shp
C:\01_TOOLSY02_Outputioutput_abigfave.shp
C:\01_TOOLsY2_Outputloutput_abstract.shp
C:\01_TOOLsY2_Outputloutput_acddent.shp
C:\01_TOOLsY2_Outputloutput_action.shp
C:\01_TOOLsY02_Outputloutput_acton.shp

+|_1 m

Output Dataset
C:\01_TOOL5 TagClusterMergeAll. shp

CIEIEIIE Y

5

-

m

-

[ Ok ] [ Cancel ] [Enuironments... ] [ Show Help == ]




TagClusterMergeAll

Shape *

ARGET FID | Views | FREGQUENC COUNT User UM FREGQUE | ImpT. TagCounts | HImpT.

L4 [ § Pohlvgon 4 ] &24 1 1 4 | afternoon 1136 ]
1 [ Pohvgon 3 1 540 2 3 | afternoon 1136 ]
2 | Polygon 3 2 1547 = S —r =
3 | Pohvgon 1 1] 8 530 Calculate Weights = | =
4 | Polvgon 1 ] 427
5 | Pohygon 1 0 11 i
& | Polygon 1 0| 248 Lo
7 | Polygon 1 0 210 C:\01_TOOLS\TagClusterMergeall.shp
& [ Polvgon 1 ] 5
9 [ Polygon 1 0| 538 LIl

10 | Pohygon 1 1] 12 C:\01_TOOLS\TagClusterMergeall_Weights.shp
11 | Pohygon 1 1] 5

v

Weights Formula
e 1+ [Join_Count] *(zqgr(1/{ [Join_Count] / [COUNT_User] J~3))

Ok Cancel Environments. .. S5 Help =

Merged results file contains a list of all Tag Clusters:

[Join__Count] = Number of Photos in each Cluster

b‘;

[Views] = Sum of Views for Photos in each Cluster
[COUNT_ User] > Number of Photographers

[ImpTag] > Tag Cluster Name
- Weights are used to calculate Font Size
- To Calculate Weights, ...

use Tool PhotoGeotag Tools > “Calculate Weights”




Extent
Top: 4994509.695500m

Left: 475903,809400 m Right: 752370,415300m

Bottom: 4692320.337300m

Data Source
T.ahh! Of Contents Shapefile Feature Class
g < @ IE : PhotoTags_Mergeall_Weights

E:'Promation_2014-04-1401_Daten‘\Arcgis\CanadaTo
E = Layers : Simple

= [0 Tags ; Faolygon
=WEY GTA_AlTagsMergeSk_SortedWeightTags, @ CopY

= [0 GTA_AlTagsMergeSk_SortedWeightTags X Remove

-

| b

= [ GTA_AlTagsMergeSk_SortedWeightTags, Joins and

> [ Set Data Source...

- Open your copy of BasemapLayout.mxd

- Use existing symbolization for Tags-Layers:
Right Click First Layer > Properties > Data Source
- Click Set Data Source and Choose

Merged Results File from previous step

- Repeat process for next two tag layers




AllTags1000_Merge_Weights

FID Shape * Join_Count TARGET FID | Views | FREQUENCY | COUNT User | SUM FREQUE | ImpT. HImpT. Weights

2872 | Polygon 45339 0| 1126 235 235 4539 | waterloo 1 §54.471418

1445 | Polygon 3573 0 | 571855 158 158 3578 [ kitchener 1 §34.202093
3355 | Pohygon 609 0 S7926 i7 T7 609 | cambridge 1

2307 | Polygon 145 1 18768 37 3r 149 | river 119437815

1114 | Polygon o3 0| 23508 30 30 &3 | grandriver 1 [ 18.038855

e - - 22 40 | church 1 [17.315637

- - 23 &3 | train 1 17.2629

42 349 | park 1 15570055

| General I Source | Selection | Display | Symbology | Fields | Definition Cluery E H 149 | gatt 1 15.14

16 21 | bridge 1 [§14.965045

Definition Query: 18 32 | water 1 14.5

"Weights™ == 20 AMND "HImpTag” = 1

) )

AC D O ©
= =

- Tags are placed on the map in the following sequence:

First, most used tags (largest font size) are placed in background

Layer 3: Weights > x AND [HImMP] =1

Second, each cluster with the most occurrences for each tag is placed:

Layer 1: Weights < x AND [HIMmMP] =1

Finally, all other tags are placed:

Layer 2:[HImP] =0

- Edit Definition Query (Layer Preferences) to select the number of tags
which should get placed in background:

Example:

Definition Query "Weights" >= 20, all labels with weights over 20 are

placed in background.




Lrvms ememe

[ Append ] [ Show Values. .. ] Display coded value description

Expression
[ Loverpropere — Write the expression in the language of the selected parser. [ Advanced

General | Source | Selection | Display | Symboiogy | Fields | Defintion Query | Labels | Joins & Relates [ Time | HTML Popup

Label features in this layer
ot [istieienmbe e, d P+ name ="Arial size=" & FEERIETRISNEE & ™>" & [ImpTag] & "</FNT>

Alfeatures will be labeled using the options specied

[ Bemsson..

@] Aral -8

me zu
Other Options Pre-defined Label Style

Placement Properies.. | | ScaleRenge.. | Label Styles.. 4 |
s |

Par=zer: [UES::ript

- The Font Size Modifier is used to adjust Fonts to your final map
display size (Paper Size)

- For each tag layer, go to ...

Layer Properties = Labels > Expression

- Adjust Modifier: 7+sqgr([Weights])*5

7 = Set minimum Font Size
- Sgr = optional flattening of font size display curve
* 5 = Set largest Font Size




Labeling = u/é = Q y.&} B Fast

View Unplaced Labels

Draw the labels that could not be
placed. The unplaced label color
can be changed on the Labeling

Options dialog.

| i AT
| CHEFlFlYE‘-k_GfB GG HERRY o e e

- final map display depends on several criteria:

- Use different Aggregation Distance [AD] if information resolution is too
fuzzy, or too many duplicate clusters exist (AD too small)

- Use different weighting formula, examples:

1+ [Join_Count] *(sqr(1/( [Join_Count] / [COUNT_User] )"™3)) - Standard weighting formula

1+ [Join_Count] *(sqr(1/( [Join_Count] / [COUNT_User] )"™2)) - less importance on User_Count in correlation to
photo count [Join_Count]

sqr(([Join_Count]+(2*sqr([Join_Count])))*2) - Ignores User_Count, this will emphasize

individual and very active users

- Use Right-Click > Labeling = “View Unplaced Labels” to verify tag
placement, .
..red labels are labels not placed on the map due to label density issues
- Adjust Font Size Modifier if Fonts are too large or small,
or placed too far off J
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